Deployment Wizard scan shows installed Agents as “Package Older” or “Package Newer”
search cancel

Deployment Wizard scan shows installed Agents as “Package Older” or “Package Newer”

book

Article ID: 428425

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

When using Deployment Wizard to scan a range of IP, some machines that already have the Agent installed, appear as “Package Older” or “Package Newer”.

This behavior even happens when trying to scan the Domain Manager itself:

Environment

Client Automation 14.6.0

Cause

This behavior happens because the DM Primer is comparing version numbers during the scan, but one of those number, which is hidden, creates a mismatch:

| cdmprimer.cpp              | 5489  | Calling MsiGetProductInfo <{<UUID>}>

| cdmprimer.cpp              | 5497  | Installed Product Version - 14.6.0/6

| cdmprimer.cpp              | 5865  | Comparing 14.6.0/14.6.0

| cdmprimer.cpp              | 5872  | verToken1 14

| cdmprimer.cpp              | 5872  | verToken1 6

| cdmprimer.cpp              | 5872  | verToken1 0

| cdmprimer.cpp              | 5886  | verToken2 14

| cdmprimer.cpp              | 5886  | verToken2 6

| cdmprimer.cpp              | 5886  | verToken2 0

| cdmprimer.cpp              | 5899  | Comparing 14/14

| cdmprimer.cpp              | 5899  | Comparing 6/6

| cdmprimer.cpp              | 5899  | Comparing 0/0

| cdmprimer.cpp              | 5899  | Comparing 11382784/13720944

| cdmprimer.cpp              | 5916  | return result -1

| cdmprimer.cpp              | 5590  |  rc is 4

| cdmprimer.cpp              | 5674  | nNumberOfCodes 4/older<4>/newer<0>/deployed<0>

Resolution

Open a support case and request fix T533409.

Additional Information

This is an Agent fix, which means it needs to be applied on all machines that have an Agent installed.