Configuring Microsoft Entra Authentication Support in Workflow Process Manager Portal for ITMS Workflow Solution 8.8.1
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Configuring Microsoft Entra Authentication Support in Workflow Process Manager Portal for ITMS Workflow Solution 8.8.1

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Article ID: 428410

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Updated On:

Products

IT Management Suite

Issue/Introduction

An administrator needs to configure the Workflow Process Manager Portal in ITMS Workflow Solution to use Microsoft Entra (formerly Azure Active Directory) authentication. This configuration enables multi-factor authentication support for the Process Manager Portal, aligning it with the security posture of the ITMS console and Software Portal.

Environment

ITMS 8.8.1
Symantec Workflow Solution 8.8.1

Cause

The Workflow Process Manager Portal is not configured to redirect authentication challenges to the organization's Microsoft Entra tenant, or the required credentials and settings have not been enabled in the Workflow Server and Process Manager Console.

Resolution

The Workflow Process Manager Portal is a separate module from the main ITMS/Symantec Management Platform Console. To enable Microsoft Entra authentication, several key steps must be completed:

  • configuring the underlying IIS web server for HTTPS,
  • registering the Process Manager server as an application in your Microsoft Entra tenant,
  • adding the Entra credentials to the Workflow Server,
  • and finally, enabling the authentication provider and provisioning authorized users within the Process Manager Portal.

Refer to our online document called "Entra Authentication Support in Workflow Process Manager Portal" for the required steps to follow.