HCX Manager UI is inaccessible showing a blank white page
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HCX Manager UI is inaccessible showing a blank white page

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Article ID: 428407

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Updated On:

Products

VMware HCX

Issue/Introduction

  • In VMware HCX, the Manager UI may become unresponsive and display a blank white page.
  • Trying to login via 443 or vCenter plugin shows the same white page.
  • While the web interface is inaccessible, the appliance may still respond to ICMP pings and SSH sessions.
  • High CPU load averages observed via the top command
  • /common/logs/zookeeper.log may report expiring sessions : 
    • 20##-##-## 13:##:##,7## [myid:] - INFO  [NIOWorkerThread-9:o.a.z.s.NIOServerCnxn@342] - Unable to read additional data from client, it probably closed the socket: address = /127.0.0.1:60612, session = 0x1000######c0000
      20##-##-## 13:##:##,7## [myid:] - INFO  [NIOWorkerThread-16:o.a.z.s.NIOServerCnxn@342] - Unable to read additional data from client, it probably closed the socket: address = /127.0.0.1:60614, session = 0x100000######001
      20##-##-## 13:##:##,7## [myid:] - INFO  [NIOWorkerThread-1:o.a.z.s.NIOServerCnxn@532] - Processing srvr command from /127.0.0.1:35202
      20##-##-## 13:##:##,7## [myid:] - INFO  [NIOWorkerThread-2:o.a.z.s.NIOServerCnxn@532] - Processing srvr command from /127.0.0.1:35204
      20##-##-## 13:##:##,7## [myid:] - INFO  [SessionTracker:o.a.z.s.ZooKeeperServer@730] - Expiring session 0x10000########4a, timeout of 4000ms exceeded
  • /common/logs/httpd/error.log may report timeut expired events : 
    • [Thu ### ## ##:##:##.041785 2026] [proxy_http:error] [pid 5##4:tid 5683] (70007)The timeout specified has expired: [client ###.##.38.##:32888] AH01102: error reading status line from remote server 127.0.0.1:8443
      [Thu ### ## ##:##:##.041991 2026] [proxy_http:error] [pid 5##4:tid 5677] (70007)The timeout specified has expired: [client ###.##.###.##:64207] AH01102: error reading status line from remote server 127.0.0.1:8443
      [Thu ### ## ##:##:##.042457 2026] [proxy_http:error] [pid 5##4:tid 5675] (70007)The timeout specified has expired: [client ##.##.###.##:60900] AH01102: error reading status line from remote server 127.0.0.1:8443

Environment

VMware HCX

Cause

  • This issue is caused by resource exhaustion OR disk I/O latency.
  • When the system cannot process requests within the defined timeout periods, internal services (Zookeeper and Java-based web services) become desynchronized, leading to an unresponsive UI.

Resolution

  • Restart the Appliance: Power cycle the HCX Manager appliance from the vSphere Client to clear the hung state and restore UI access.
  • Ensure the appliance is residing on a storage backing that can handle high I/O bursts. Avoid placing the Manager on heavily congested or slow mechanical storage tiers.
  • Increase the CPU reservation for the HCX Manager appliance if high-churn operations are expected in the environment.

Additional Information

Refer to article 373010 for scalability guide.