ESXi host enters "Not responding" state after update due to incorrect IPv6 name resolution
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ESXi host enters "Not responding" state after update due to incorrect IPv6 name resolution

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Article ID: 428355

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

After updating an ESXi host, the ESXi host gets Not responding state in the vSphere Client.

Manually reconnecting the ESXi host succeeds, but the host reverts to the Not responding state within a few minutes.

The ESXi host and vCenter Server have both IPv4 and IPv6 addresses.

The DNS server resolves the IPv4 address for the ESXi host correctly; however, it returns an incorrect IPv6 address (AAAA record) for the same host.

Environment

VMware vSphere vCenter Server 8.0

VMware vSphere ESXi 8.0

Cause

This is due to the incorrect IPv6 name resolution for the ESXi hostname in the DNS server.

When an ESXi host is updated, vCenter Server automatically disconnects and reconnects the ESXi host. On reconnecting, vCenter Server gets the IP address for the ESXi hostname, and the IP address is pushed to ESXi host as the IP address for communication with the vCenter Server. If the resolved IPv6 address is incorrect, the ESXi host does not have the IPv6 address and cannot send heartbeats to the vCenter Server. This makes the vCenter Server mark the host as Not responding state.

Resolution

1. Correct the IPv6 (AAAA) record for the ESXi hostname in the DNS server.

2. SSH into vCenter Server and log in with root credentials.

3. Restart dnsmasq service to clear DNS cache.

# systemctl restart dnsmasq

4. Check if the name resolution is correct

# dig __FQDN_OF_ESXI_HOST__ AAAA

5. In the vSphere Client, right click the ESXi host > Connection > Disconnect, and click OK in the confirmation popup.

6. Right click the ESXi host > Connection > Connect, and click OK in the confirmation popup.