HCX Migration Fails with “Initial Sync Failed – Error Running Request”
search cancel

HCX Migration Fails with “Initial Sync Failed – Error Running Request”

book

Article ID: 428268

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Virtual machine migration using VMware HCX fails with the error:

“Initial Sync Failed – Error Running Request”

  • Migration failures occur while using an existing HCX Interconnect (IX) appliance.

  • ESXi host to IX appliance:- nc -zv IX appliance IP port 31031 - Succeeds.

  • ESXi vmkernel.log : 

2026-02-05T17:57:41.860Z In(182) vmkernel: cpu4:77731008) Hbr: 2739: Failed to establish connection to [10.##.##.##]:31031 (groupID=VRID-9d449bda-####-####-####-############): Broken pipe

2026-02-05T17:57:41.860Z In(182) vmkernel: cpu4:77731008)Hbr:2739: Wire Compression supported by server 10.##.##.##:FastLZ

Environment

VMware HCX

Cause

The issue occurs when the HCX concurrent migration limit per Service Mesh is exceeded.

Resolution

Per HCX Manager. 300 Concurrent migrations in any state.

A single HCX Service Mesh supports a maximum of 200 concurrent migrations.

When the limit is exceeded, the IX appliance fails to establish a required connections, resulting in migration failures.

To address the issue, perform the following steps:

  1. Scale the HCX Manager to support higher concurrent migration limits per HCX Manager.

  2. Deploy an additional HCX Service Mesh, which provisions a new IX appliance.

  3. Distribute migration workloads across multiple Service Meshes.

  4. Retry the failed migrations.

Additional Information

VMware Configuration Maximums