"500 Routing Failed" Error when Backing Up the API Gateway via a Web Browser using the Gateway Backup Service
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"500 Routing Failed" Error when Backing Up the API Gateway via a Web Browser using the Gateway Backup Service

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Article ID: 42822

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Updated On:

Products

CA API Gateway

Issue/Introduction

The "500 Routing Failure" error is seen when backing up the API Gateway using the Gateway Backup Service (*/ssg/backup) via a web browser.

Environment

All supported versions of the API Gateway

Cause

The API Gateway node does not trust the certificate found on the other node in the cluster.

Resolution

To prevent this error from occurring and enable a successful backup, the individual gateways must trust the certificate assigned to the port being used for the backup. This can be accomplished by importing the SSL certificate from any of the gateways via the Manage Certificates utility in the CA Policy Manager (previously known as the Layer 7 Policy Manager).

  1. Open up the Policy Manager, click on the Tasks > Manage Certificates.

     

  2. In the Manage Certificates dialog box, click Add.

     

  3. In the Add Certificate Wizard select Import from Private Key's Certificate Chain and then choose the certificate used for the port from the drop-down menu and click Next.

     

  4. Click Next again then make sure to select Outbound SSL Connections (we recommend checking the next three as well) and click Next.

     

  5. At the last page in the wizard select Certificate is a Trust Anchor and then click Finish.

       

    6. Navigate to the API Gateway node where the initial error was encountered and attempt another backup. You should see the backup file ready for download instead of the "500 Routing Failed" error message seen previously.

 

       

Additional Information