Disconnecting RDP causes PAM client to crash with a Java exception
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Disconnecting RDP causes PAM client to crash with a Java exception

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Article ID: 428199

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

CA PAM client crashes in a specific use case:

* User executing PAM client from a remote machine

* The remote machine is accessed from a RDP session

* After a disconnection and reconnection of the RDP session, the client crashes.

In the CA PAM installation directory there are java core dump hs_err_pid<pid>.log files which point to errors in the following area

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007fffdd65c8b1, pid=7308, tid=2832
#
# JRE version: OpenJDK Runtime Environment Temurin-17.0.13+11 (17.0.13+11) (build 17.0.13+11)
# Java VM: OpenJDK 64-Bit Server VM Temurin-17.0.13+11 (17.0.13+11, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)
# Problematic frame:
# C  [awt.dll+0xdc8b1]

 

Environment

CA PAM Client 4.2.1 with OpenJDK 17.0.13_11

Cause

Upon analysis of the JVM crashes, all were showing failures occurring in native Windows AWT (awt.dll) on the AWT event threads, consistently showing EXCEPTION_ACCESS_VIOLATION outside the JVM.

Stack traces indicated crashes during Windows graphics/DPI handling (Win32GraphicsDevice.initNativeScale, WToolkit.eventLoop). This confirms a native AWT rendering issue on Java 17 for Windows, not an application-level Java defect.

Disabling hardware acceleration or running on Java 11 may fix this behavior.

Resolution

Go to PAM Client installation folder, 
- Right click on CAPAMClient.exe 
- select Properties
- select Compatibility tab
- click on Change high DPI settings
- check 'Override high DPI scaling behavior
- Then select 'Application' from 'Scaling performed by:' drop down
- Press OK