Custom Compliance Benchmark results are not visible in VCF Operations 9.x when applied to non-default (child) policies
search cancel

Custom Compliance Benchmark results are not visible in VCF Operations 9.x when applied to non-default (child) policies

book

Article ID: 428080

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In VCF Operations 9.x, you may observe that Custom Compliance Benchmarks appear to work correctly on the default (parent) policy but shows No objects assessed when a non-default (child) policy is selected. This issue typically occurs when a custom policy is configured to include only specific vCenter objects. However, it works in Aria Operations 8.18.x.

Environment

VCF Operations 9.x

Cause

The root cause is a change in the default tab selection on the Compliance page.
  • In Aria Operations 8.18.x, the vCenter tab is the first in the list and selected by default.
  • In VCF Operations 9.x, the VCF tab is now the first in the list and is selected by default.
If your policy specifically targets vCenter objects, the VCF tab will show no assessed objects, creating the appearance that the benchmark is not working.

Resolution

To view your Custom Compliance Benchmark results, you must manually switch the context to the correct object tab:
  1. Log in to the VCF Operations UI.
  2. Navigate to the Security > Compliance page.
  3. Observe that the VMware Cloud Foundation tab is selected by default.
  4. Click on the vCenter tab in the top navigation list.
  5. Once you click on the vCenter tab, it will list all available Compliance Benchmarks. 
  6. Verify that your custom benchmark and valid calculations are now visible for the objects included in your policy.