ESXi coredump file becomes inactive after upgrading to version 9.0.2
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ESXi coredump file becomes inactive after upgrading to version 9.0.2

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Article ID: 428015

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  1. After upgrading an ESXi host to version 9.0.2, the diagnostic coredump file becomes inactive.

  2. Running the esxcli system coredump file list command shows the Active and Configured statuses as false
    esxcli system coredump file list
    Output seen:
    Active: false
    Configure: false  

Environment

VMware vSphere ESXi 9.0.2

Cause

The ESXi host deactivates the existing diagnostic coredump file during the 9.0.2 upgrade process when dynamically resizing the dump target, but fails to reactivate the newly created dump file automatically.

Resolution

Broadcom is aware of this issue and will be fixed in future release

To resolve this issue in ESXi 9.0.2, apply one of the following workarounds:

Workaround 1:

  1. Connect to the affected ESXi host as root via SSH or the ESXi Shell.

  2. Run the following command to automatically configure and enable the smart coredump file:
    esxcli system coredump file set --smart --enable true

Workaround 2: 

  1. Place the affected ESXi host into Maintenance Mode.

  2. Reboot the host. The coredump file successfully activates during the boot sequence.

After following any of the above workaround to confirm the coredump file is active, run the following command:

esxcli system coredump file list

Ensure the output displays true for both the Active and Configured columns.