Active Directory ユーザーで vCenter Server にログインしようとすると、「このクライアントに接続されたすべての vCenter Server システムに対して権限がないため、ログインできません。」というエラーが表示される
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Active Directory ユーザーで vCenter Server にログインしようとすると、「このクライアントに接続されたすべての vCenter Server システムに対して権限がないため、ログインできません。」というエラーが表示される

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VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

免責事項:これは英文の記事「Error: "Unable to login because you do not have permission on any vCenter Server systems connected to this client" when trying to login to vCenter Server with Active Directory user」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • vCenter Server へのログインに失敗します。
  • 次のようなエラーが表示されます:
    このクライアントに接続されたすべての vCenter Server システムに対して権限がないため、ログインできません。

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

この問題は、ユーザーアカウント(Active Directory ユーザーまたはローカルユーザー)に vCenter Server へログインするための適切な権限がないために発生します。

デフォルトでは、vCenter Server のローカル管理者グループ(administrators group)のみが vCenter Server へのアクセス権を持っています。管理者グループのメンバーではないユーザー(直接的なメンバー、または他のグループを介した間接的なメンバーのいずれでもない場合)としてログインしようとすると、そのユーザーアカウントにはインベントリ内のどのオブジェクトに対しても権限がないため、ログインは失敗します。

注:vCenter Server が Active Directory ドメインに接続されている場合、デフォルトでは Domain Admin グループがローカル管理者グループのメンバーとなります。

Resolution

vCenter Server にログインできないユーザーのトラブルシューティング:

  1.  同じ権限を持つ別のユーザーで vCenter Server にログインし、挙動がその特定のユーザー固有のものかどうかを確認します。
  2.  別のユーザーがログインできる場合は、ローカル管理者アカウント([email protected])を使用して、問題のあるユーザーに適切な権限を追加します。

ユーザーに権限を追加するプロセス:

  1.  インベントリから vCenter オブジェクトを選択します。
  2.  [権限 (Permissions)] タブをクリックします。
  3.  [権限の追加 (Add Permission (+))] をクリックします。
  4.  権限の追加が必要なユーザーを入力します。
  5.  必要な権限に応じて、ユーザーのロールを選択します。注意:「アクセスなし (No access)」ロールを割り当てると、そのアカウントに他のロールが既に割り当てられていない限り、ユーザーはログインできなくなります。 

詳細な権限の情報については、「vSphere Permissions and User Management Tasks」を参照してください。