NSX Manager support bundle creation process hangs, stuck at "In Progress" status at 0%
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NSX Manager support bundle creation process hangs, stuck at "In Progress" status at 0%

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Article ID: 427836

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to create a support bundle for an NSX manager node, the process stays at "In Progress' and never moves past 0%.
    • This process may eventually time out.
  • Generating a support bundle from the command line (via the get support-bundle command) also appears to hang and may eventually time out.
  • Messages similar to the following may be present in the /var/log/syslog file on the NSX manager node where the support bundle is being generated:
    2026-01-23T15:52:19.290Z ######## NSX 3217517 - [nsx@4413 comp="nsx-manager" subcomp="sbundle-collect" username="root" level="WARNING"] Support bundle generation timed out
    2026-01-23T15:52:19.306Z ######## NSX 1980 - [nsx@4413 comp="nsx-manager" subcomp="opsagent" s2comp="sbundle" tid="2094" level="ERROR" errorCode="OPS60014"] Error invoking collect script, ret: 124, output: , error: Support bundle generation timed out
    2026-01-23T15:52:19.308Z ######## NSX 1980 - [nsx@4413 comp="nsx-manager" subcomp="opsagent" s2comp="sbundle" tid="2094" level="ERROR" errorCode="OPS60014"] Bundle request failed, rc: 124, out: , err: Support bundle generation timed out
  • Messages similar to the following will not be present at the end of the /var/log/support_bundle.log file on the NSX manager node where the support bundle is being generated:
    2026-01-27 17:24:39,180 1551365 root INFO Adding log content
    2026-01-27 17:24:39,181 1551365 root INFO Finished adding log contents (0.000) of: /var/log/unattended-upgrades
    2026-01-27 17:24:44,643 1551365 root INFO Finished adding log contents (5.461) of: /var/log/corfu
    2026-01-27 17:24:45,119 1551365 root INFO Finished adding log contents (0.329) of: /var/log/corfu/jvm
    2026-01-27 17:25:23,115 1551365 root INFO Finished adding log contents (37.993) of: /var/log/proton
  • On the System > Appliances > Appliance Details page for the affected NSX manager node, the REPO_SYNC service is in a FAILED state.
    •  A message similar to the following may be present on the System > Appliance page:

      Repository synchronization was interrupted on <IP> node. Click Resolve to retry.

    • Clicking Resolve does not change the status of the REPO_SYNC service.
  • If an upgrade was recently initiated, it may fail on the pre-check phase with a message similar to the following:

    error_message:Read timed out, httpStatus:, error_code:0

    • Gaps in logging for the upgrade-coordinator service may be seen, indicating an initialization delay with the process

      In the /var/log/upgrade-coordinator/localhost_access_log.txt file there may be a large period of time between log entries:
      2026-01-22T23:06:39.874Z 127.0.0.1 - - "POST /upgrade-coordinator/api/v1/upgrade/bundles?action=upload&install=true HTTP/2.0" 200 39
      2026-01-27T16:06:04.366Z 127.0.0.1 - - "GET /upgrade-coordinator/api/v1/upgrade/eula/acceptance HTTP/1.1" 200 36

Environment

VMware NSX 4.1 and above

Cause

The REPO_SYNC process on the NSX manager node never releases a lock which causes subsequent processes to hang.

Resolution

This is a known issue affecting VMware NSX 4.1 and above. There is currently no resolution.

To workaround this issue, reboot the affected NSX manager node.