workflow (wf) factory restricted GET operation error
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workflow (wf) factory restricted GET operation error

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Article ID: 427830

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Users attempting to retrieve data via the CASM Reports API encounter a 500 Internal Server Error when calling the workflow (wf) object. This occurs because the wf factory is currently restricted from GET operations within the Reporting API framework.

When performing a GET request for the wf object/factory via the CASM Reports API, the system returns the following error: 500 "The factory wf is restricted for GET operation"

Environment

  • Release: Service Management 17.4 RU4 and later
  • Component: CASM Reports API
  • Deployment: Conventional (On-Premise) and Advanced Availability
  • Database: All supported vendors (Oracle, MS SQL Server)

Cause

As of February 2026, the wf (Workflow) object is not currently supported for data retrieval via the CASM Reports API. The API is designed to support a specific subset of Service Desk Manager factories for reporting purposes.

Resolution

There is currently no direct workaround to enable the wf factory in the CASM Reports API.

Supported Objects The following factories are currently supported for use with the CASM Reports API:

  • in (Incidents)
  • cr (Requests)
  • pr (Problems)
  • nr (Assets/Configuration Items)
  • chg (Change Orders)
  • iss (Issues)

Additional Information

If your business requirements require the wf factory to be available via the CASM Reports API, please submit an Idea or Enhancement Request at the Broadcom Community link below: 

See also:  Generating CASM Reports with APIs