Aria Operations for Logs UI is Stuck Spinning/Loading vSphere Integrations
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Aria Operations for Logs UI is Stuck Spinning/Loading vSphere Integrations

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Article ID: 427779

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When accessing the vSphere Integration configuration page in the Aria Operations for Logs user interface, the integration details fail to load and keep on spinning.

  • When attempting to add a vCenter host, users encounter the error message: 'configuration with specified vCenter server hostname already exist'


  • The integration could not be deleted using the API.

Environment

VMware Aria Operations for Logs 8.18.x

Cause

The integration could not be viewed or managed via API due to connection failures; specifically, the vCenter's attempts to reach Aria Operations for Logs were repeatedly timing out.

Resolution

Follow the step below to resolve the issue:

  1. Add the vCenter server hostname in the file :/etc/hosts/.
    vi /etc/hosts/

    Note: The format should be vCenter_IP  vCenter_FQDN 

  2. Follow the steps from KB article to Obtain a sessionId to Authorize APIs in the Swagger UI
  3. Scroll through the swagger page to find 'VSPHERE'  and input the UUID for the vCenter and Execute.

    Note: the vCenter UUID can be found in /storage/core/loginsight/config/loginsight-config.xml
  4. Scroll down to the Server response to verify Code 200 for successfully removed the integration configuration for vCenter Server.
  5. Verify the vSphere integration has been successfully removed from the Aria Operations for Logs UI.

You can now add vCenter integration back to into Aria Operations for Logs using the UI if required.