Automic job is unable to retrieve data from Catalog Web Service
search cancel

Automic job is unable to retrieve data from Catalog Web Service

book

Article ID: 427664

calendar_today

Updated On:

Products

CA Service Catalog Automic Automation

Issue/Introduction

Automic job is consuming executeDataObject Service Catalog Web Service method to get data from usm_link_ticket_request_item with a STRING Parameter.

This works OK when consuming directly via SOAP UI but it does not work when running an Automic job.

Environment

Service Desk Manager and Service Catalog 17.4.x

Automic Automation

Cause

The Automic job runs too fast and does not allow for the Service Management applications (Service Desk Manager and Service Catalog) to complete the process which includes populating the internal table named: usm_link_ticket_request_item.

Resolution

The usm_link_ticket_request_item table is populated once the SDM ticket is created via SDM WS and linked to the request. This process involves Catalog triggering the action, connecting to the WS, obtaining a session ID, creating the ticket, and finally updating the table. 

Since the process above can take some time, It's necessary to add a delay/WAIT parameter in the Automic Job Worklow to allow the sequence to be completed.

Additional Information

Service Catalog and Automic Integration