Configure a Syslog Server in the HCX Manager for troubleshooting purposes
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Configure a Syslog Server in the HCX Manager for troubleshooting purposes

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Article ID: 427660

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Updated On:

Products

VMware HCX

Issue/Introduction

HCX Manager bulk migrations may be configured for a duration (for example: 20+ days ago) longer then the /common/logs/admin/app.log is able to store.  HCX Managers that have several bulk migrations setup at one time will cause the /common/logs/admin/app.log to overwrite the log more frequently and thus overwriting critical historic logs needed to troubleshoot migrations that were configured prior to an issue occurring.

The /common/logs/admin/app.log does not contain log entries from the start of when a mobility group was created.    

Environment

VMware HCX

Cause

Long running Migrations (For example 20+ days) or HCX Managers that have several migrations in place at one time will cause the /common/logs/admin/app.log to fill quickly and rotate the log overwriting necessary log entries written during the beginning stages of an HCX Bulk Migration.  Required troubleshooting logs will no longer be present in the HCX Manager and older logs will need retreived from the syslog server

Resolution

It is recommended to configure a syslog server in the HCX Manager so older logs written to /common/logs/admin app.log and web.log can be retreived from a syslog server for troubleshooting Bulk Migrations

Adding a Remote Syslog Server in the HCX Manager

  1. Log in to the HCX Manager user interface:  https://<hcx-ip-or-fqdn>:9443.
  2. Navigate to Administration -> General Settings -> Syslog Server -> Edit
  3. Enter syslog server IP address > Save

 

For existing deployed appliances, perform a "Force Sync" operation from the HCX Manager UI: https://<hcx-ip-or-fqdn>

  1. Interconnect -> Service Mesh -> View Appliances -> <Select Appliance Name> -> Force Sync

Additional Information

The following Techdoc also provides the procedure to add a syslog Serverr ( vRLI):  Adding a Remote Syslog Server

 

The following KB article provides troubleshooting steps for HCX Managers configured to use vRealize Log Insight as a syslog server.  This will assist with future troubleshooting as long as the retention of the logs in vRLI is long enough to capture the beginning of a migration (30-60 days or duration of a migration)  Troubleshooting Syslog Traffic from HCX Manager to vRealize Log Insight (vRLI)