Agent upgrade error
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Agent upgrade error

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Article ID: 427651

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Updated On:

Products

Workload Automation Agent ESP dSeries Workload Automation - System Agent (dSeries) ESP dSeries Workload Automation - Business Agents (dSeries)

Issue/Introduction

While upgrading System Agent to v24.0 on a server, we got below error. Can you please help us figure out which plugin we need to upgrade to fix this error?

===============================================================================
Agent Upgrade Confirmation
--------------------------

You are using below old release POJOs , these POJOs will not work with 12.1 or
above. Do you want to proceed further with upgrade (y/n). please contact
Broadcom Support to get the latest release POJOs

Secure iNet Factory


  ->1- Abort
    2- Continue

ENTER THE NUMBER OF THE DESIRED CHOICE, OR PRESS <ENTER> TO ACCEPT THE
   DEFAULT: 2

Environment

Workload Automation Agent

Cause

The message is informational rather than an error. It occurs because old agent version (11.3.x) uses an older release of the POJOs Plugin Extension, which is not compatible with agent versions 12.1 and higher.

Resolution

As an option, you can proceed with the upgrade (Option 2) and then apply the latest versions of the POJOs Plugin Extension to the agent once the upgrade is complete.

To identify which POJOs Plugin Extension needs to be upgraded, follow these steps:

  1. Run the following command from the agent installation directory:
    • Linux/UNIX: ./cybAgent -vv
    • Windows: cybAgent.exe -vv
  2. Locate the section "Plugin Extensions Configured on Agent:" to see the list of plugin extensions.
  3. Download the corresponding plugin extensions from the Automation Marketplace.
Ensure to follow the installation instructions for the specific provided in the documentation.