Tanzu Kubernetes Grid Integrated Management Console(TKGIMC) upgrade fails with error "failed to load installation file"
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Tanzu Kubernetes Grid Integrated Management Console(TKGIMC) upgrade fails with error "failed to load installation file"

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Article ID: 427629

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Updated On:

Products

VMware Tanzu Kubernetes Grid Integrated Edition

Issue/Introduction

When upgrading TKGI with TKGIMC, the upgrade fails and you see error in pks-mgmt-server log (which can be obtained by `docker logs pks-mgmt-server ` in TKGIMC VM): 

time="2025-12-28T11:34:11Z" level=info msg="Deleting the new opsman VM[opsman-####] created for upgraded version due to upgrade error :failed importing settings to new Ops Manager: failed to load installation file: open /tmp/pksimport/OMSettings.zip: no such file or directory"
time="2025-12-28T11:34:11Z" level=info msg="Update for deployment #### - Deploy ops-manager 3.0.41+LTS-T: state(  failed) failed importing settings to new Ops Manager: failed to load installation file: open /tmp/pksimport/OMSettings.zip: no such file or directory\n"
time="2025-12-28T11:34:11Z" level=info msg="Resuming the earlier running opsman with VMMoid:vm-#### due to upgrade process error:failed importing settings to new Ops Manager: failed to load installation file: open /tmp/pksimport/OMSettings.zip: no such file

Environment

Tanzu Kubernetes Grid Integrated Management Console

Cause

When upgrading TKGI with TKGIMC, the newly created TKGIMC instance connects to previous instance and fetches all needed information. One step is to export Operations Manager and TKGI configurations for later use. If the previous TKGIMC instance is at temporarily unhealthy state, this export step could partly fail, as the result, OMSettings.zip was not properly exported from previous Operations Manager. TKGIMC does not retry so that it will keep reporting the error because of the missing configuration file. 

Resolution

In this situation, please review previous TKGIMC instance, make sure all components(Operations Manager, BOSH, TKGI, etc)are reported healthy. If any components are reported DOWN or unhealthy, please resolve the problem prior to upgrade, then follow product document to deploy a brand new TKGIMC instance to continue the upgrade.