SIP VS Error: Server Sent a SIP Message with Unknown Call-ID Header
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SIP VS Error: Server Sent a SIP Message with Unknown Call-ID Header

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Article ID: 427620

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • SIP calls may fail or get dropped unpredictably.
  • SIP Virtual Server (VS) intermittently logs the significant log: “Server sent a SIP message with unknown CallId header.”

Cause

This issue typically occurs in scenarios when a single Virtual Service is configured to handle both UDP and TCP transport protocols for SIP traffic. 

Resolution

Workaround

  1. Configure two pools (say pool1 and pool2) with the same set of backend servers, one for TCP and one for UDP connections. 

    Reference techdoc for configuring pool: creating-pool 
  2. Create two separate SIP Virtual Servers (VS) sharing the same VIP:

    • One VS configured with a UDP network profile, associate it with the pool1

    • One VS configured with a TCP network profile, associate it with the pool2

Reference techdoc for configuring SIP Load balancer: Configuring-Avi-Load-Balancer-for-SIP 

Fix

The bug is fixed in 31.2.1-2p2. Please refer Avi load balancer release notes in reference to bug ID: AV-260602

Release-notes-for-avi-load-balancer-version-31-2-1