VMFS ローカルデータストアにアクセスできず、仮想マシン(VM)が使用不能になる
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VMFS ローカルデータストアにアクセスできず、仮想マシン(VM)が使用不能になる

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Article ID: 427584

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Products

VMware vSphere ESXi

Issue/Introduction

免責事項:これは英文の記事「VMFS local datastore is not accessible, VMs unusable」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

ローカル VMFS データストアの容量および空き容量が 0 と表示される。

仮想マシンが使用不能になる。

データストアは、vCenter Web Client または ESXi CLI 経由で参照できません。

データストアを操作しようとコマンドを実行すると、「No such device(そのようなデバイスはありません)」または「No such file or directory(そのようなファイルやディレクトリはありません)」というエラーが発生する。

ホストログが保存されているVMFS-Lデータストアでも同様です。

Environment

VMware vSphere ESXi (All Versions)

Cause

これは、H:0x5 (データストアで発生した中止、タイムアウト、およびスタック I/O により、データストアが使用できなくなる) が原因で発生します。

「H:0x5」ステータスは、ドライバがターゲットに対して実行中のコマンドを中断(アボート)しなければならない場合に返されます。



2025-04-05T13:58:32.275Z cpu15:2097202)ScsiDeviceIO: 4154: Cmd(0x45b901a70a08) 0x12, cmdId.initiator=0x430583b68690 CmdSN 0x10ac07 from world 0 to dev "naa.##########" failed H:0x5 D:0x0 P:0x0 Cancelled from device layer. Cmd
2025-04-05T13:58:32.275Z cpu16:2097404)ScsiVmas: 1074: Inquiry for VPD page 00 to device naa.########## failed with error Timeout
025-04-05T13:58:38.266Z cpu16:2305408)WARNING: ScsiPath: 7206: Failed to issue command 0x0 (cmdSN 0x0) on path vmhba1:C2:T0:L0: Timeout
2025-04-05T13:58:42.158Z cpu0:2097423)lsi_mr3: fusionWaitForOutstanding:4190: megasas: waiting for 1 commands to complete. Total outstanding 93
2025-04-05T13:58:51.705Z cpu13:2305372)HBX: 3063: 'datastore1 (8)': HB at offset 3702784 - Waiting for timed out HB
2025-04-05T13:58:52.266Z cpu17:2097229)ScsiDeviceIO: 12518: Task mgmt request issued to device naa.########## is stuck (WorldID 2097189, Cmd 0x28, CmdSN 1a69fd). Issuing red notification to the application

Resolution

データストアが中止、タイムアウト、スタック I/O の影響を受けており、ホスト ログにアクセスできないことを確認するには、次の手順を実行します。

  1. Access the host DCUI either by an SSH session or the hosts KVM Utility 
  2. ALT+F12 キーを押して、アクティブな vmkernel ログを表示します。
  3. DCUI 経由で VMkernel ログにアクセスできない場合は、dmesg を実行してメモリ内のアクティブなメッセージ(VMkernel ログ)にアクセスできます。
  4. 中断やタイムアウトが頻繁に発生する場合は、データストアが実質的に使用できなくなっています。
  5. ホストをメンテナンスモードに切り替え、再起動してください。
  6. ホストがメンテナンスモードに移行しない場合は、コールドリブートを実行してください。