ESXi host loses network connectivity after driver/firmware update
search cancel

ESXi host loses network connectivity after driver/firmware update

book

Article ID: 427559

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • ESXi host is disconnected from the network after a driver and/or firmware update.

  • Unable to ping the ESXi host management network IP address.
  • VMNIC numbering changed from vmnic1–vmnic4 to vmnic0–vmnic3.

  • The ESXi host is added to a vSphere Distributed Switch (VDS).

  • Resetting the network configuration did not resolve the issue.

  • Unable to access the ESXi host via ESXi Shell; attempting to do so results in a black screen.

Environment

VMware vSphere ESXi

Cause

This issue occurs due to changes in VMNIC numbering after a driver or firmware update. As a result, the physical NICs mapped to the management network are no longer correctly associated with the vSphere Distributed Switch or host networking configuration, leading to loss of network connectivity.

Resolution

To resolve the issue, reset the ESXi system configuration from DCUI and reconfigure the host. 

Reference Document:  Reset the System Configuration

Additional Information

Configuring Standard vSwitch (vSS) or virtual Distributed Switch (vDS) from the command line in ESXi