vLCM Sync Updates shows failure message "A general system error occurred" for the Compute image recommendations task.
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vLCM Sync Updates shows failure message "A general system error occurred" for the Compute image recommendations task.

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Article ID: 427524

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Initiating Sync Updates from Lifecycle Manager on vCenter Server fails with error message "A general system error occurred" for the Compute image recommendations task.



  • Lifecycle Manager log shows errors as below:

    YYYY-MM-DDTHH:MM:SS.###Z error vmware-vum-server [pid] [Originator@6876 sub-RecommendationEngine::HardwareSupportSubsystem] [hardwareSupportSubsystem 88] GetFirmwareSelections: Hardware Support Manager: com.dell.plugin.OpenManager_HwSupportManager fails with error: com.vmware.vapi.std.errors.not found
    YYYY-MM-DDTHH:MM:SS.###Z error vmware-vum-server [pid] [Originator@6876 sub=RecommendationEngine::Firmwarefilter] [firmwarefilter 212] Failed to get firmwareList for entity 'domain-<moid>' ESXi version '9.0.2.0.25148076'
    YYYY-MM-DDTHH:MM:SS.###Z error vmware-vum-server [pid] [Originator86876 sub-RecommendationEngine::ReEngine] [reEngine 170] Exception from function getFirmwareList.
    YYYY-MM-DDTHH:MM:SS.###Z error vmware-vum-server [pid] [Originator@6876 sub=RecommendationEngine::ReEngine) [reEngine 182] Failed to generate image drafts for entity domain-<moid>
    YYYY-MM-DDTHH:MM:SS.###Z error vmware-vum-server [pid] [Originator@6876 sub-com.vmware.vcIntegrity.lifecycle.CreateRecommendationTask] [CreateRecommendationTask, 82] Task:com.vmware.vcIntegrity.lifecycle.CreateRecommendationTask ID:<id>. Failed to generate software specs.

  • Dell Open Manage logs shows error as below:

    [vSphere Lifecycle Manager] Provided release version is not supported by OMEVV.

Environment

  • vCenter 9.x

Cause

This issue is caused by third party plugin (Dell OpenManage) HSM configuration on vCenter.

Resolution

Contact Dell's technical support to team to address the issue within the OpenManage plugin.

Workaround

Remove the HSM (hardware support manager) firmware configuration from the Cluster image by following below steps:

Note: This can be done only when the firmware configuration using HSM is not needed for the Cluster.

  1. Unregister the OpenManage plugin from vCenter (this is done from the Dell OpenManage console).
  2. Select the vSphere Cluster -> Click on Updates Tab.
  3. Click on Image.
  4. Click EDIT to modify the image.
  5. Under section Firmware and Drivers Addon, remove the Dell OpenManage and keep it as "None".
  6. Retry the Sync Updates task.