After Replacing or Renewing the NSX Certificate, VCF Usage Meter Stops Collecting Metering Data and Shows “Incomplete collection”
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After Replacing or Renewing the NSX Certificate, VCF Usage Meter Stops Collecting Metering Data and Shows “Incomplete collection”

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Article ID: 427352

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

After replacing or renewing the NSX certificate, VCF Usage Meter fails to connect to NSX and is unable to collect metering data.
As a result, “Incomplete collection” may be displayed in the NSX connection status.

 

Environment

VCF Usage Meter 9.0

Cause

After the NSX certificate is replaced or renewed, VCF Usage Meter cannot establish a trusted connection to NSX until the new certificate is accepted.

Resolution

Verify and Accept the Updated NSX Certificate in VCF Usage Meter

  1. Log in to the VCF Usage Meter
  2. Navigate to [Network] > NSX-T
  3. On the NSX-T page, select endopint instance and click Edit.
  4. Confirm the Usage name and Password in text boex, and click Save.
  5. Locate NSX instance that is displaying the "PLEASE ACCEPT CERTIFICATE" status in the Status column and click on the "PLEASE ACCEPT CERTIFICATE" link.
  6. Review the certificate details presented in the pop-up window and confirm your acceptance.

Once the certificate is accepted, VCF Usage Meter attempts to re-establish a trusted connection to NSX. The NSX connection status should change to “OK” shortly, and metering data collection will resume.

Additional Information

Note:
There are three categories of self-signed certificates in NSX.
For more information, refer to Types of Certificates.

In a clustered NSX-T Manager deployment, VCF Usage Meter registers only the cluster virtual IP (VIP).
Therefore, renewing certificates on individual NSX-T Manager nodes does not affect the VIP, and no action is required on the VCF Usage Meter side unless the VIP certificate itself is renewed.