NSX appliances with old core dumps
search cancel

NSX appliances with old core dumps

book

Article ID: 427334

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

Old core-dumps are found on an NSX appliance by:

  • VMware Support log analysis
  • Accessing the appliance via the admin credentials and running the command get core-dumps
  • An old alarm within the NSX UI reporting a previous application crash which generated a core dump file
    • Application on NSX node <node> has crashed. The number of core files found is 1. Collect the Support Bundle including core dump files and contact VMware Support team. Recommended Action Collect Support Bundle for NSX node <nsx manager> using NSX Manager UI or API.

Environment

VMware NSX 4.x

Cause

At the point in time the core dump was created, there may have been an issue experienced within the environment. 

Resolution

As disk space on the appliances is limited, its recommended to remove core dumps once they are no longer needed for investigation. 

  1. Verify if the appliance has core dumps by running the command get core-dumps
    • If there are recent core dumps that have not been investigated, VMware by Broadcom recommends opening a support case and uploading the following logs
    • If the core dumps are no longer needed by the end user or by VMware by Broadcom support they can be deleted by running the below commands
      • To delete all core dumps: del core-dump all
      • To delete specific core dumps: del core-dump <core dump file here>

 

Additional Information