sqlserver probe error in GUI Request failed the request failed communication error
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sqlserver probe error in GUI Request failed the request failed communication error

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Article ID: 427324

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

sqlserver v6.03 GUI configuration window would not open without error.

The probe icon turns red and fails with Max. restarts as per the sqlserver_monitor.log.

"Request failed"

"The request failed: communication error

The probe is probably not started"

Environment

  • DX UIM 23.4.0
  • IM 23.4.0
  • sqlserver v6.03
  • sqlserver v5.92-T5

Cause

  • IM configuration/stale session

Resolution

Workaround:

  1. Upgraded the robot to 23.4.4.1 via deployment of robot_update package
  2. Set IM Tools->Options to the Primary hub address at the top of IM
  3. Selected 'Receive domain events.'
  4. Selected 'Save configuration profile on exit' to save the settings for each IM session
  5. Chose File->Exit.
  6. Chose Security->Login to refresh the login.
  7. Opened the sqlserver probe GUI in IM with no issues.

We noticed that one other instance of the sqlserver probe for an older version that was opening did not have a configuration so maybe that was unconfigured or the sqlserver_monitor.cfg needed restoration (after being saved off/backed up).

To restore the desired already configured sqlserver_monitor.cfg (configuration file), 

  1. Deactivate sqlserver probe
  2. Restore the sqlserver_monitor.cfg file into the sqlserver probes folder
  3. Activate sqlserver probe
  4. Double click to open the sqlserver GUI
  5. Check the connections and profiles