Data Loss Prevention – Garbled Non-Latin Characters shown in Incident CSV Export
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Data Loss Prevention – Garbled Non-Latin Characters shown in Incident CSV Export

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Article ID: 427253

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce Data Loss Prevention Enterprise Suite Data Loss Prevention Discover Suite

Issue/Introduction

When exporting incident lists to CSV, non-Latin characters may appear as garbled or “rubbish” characters in Excel or other Windows applications. 

Languages affected (examples):

  • Chinese

  • Japanese

  • Korean

  • Arabic

  • Cyrillic

  • Greek

  • Hebrew

  • Thai

Steps to Identify:

  1. Export incidents as CSV file from Enforce console.

  2. Open it in Excel.

  3. Non-Latin characters may be displayed incorrectly.

Environment

Data Loss Prevention version 16.0

Cause

Exported incident lists and reports in CSV format were encoded in plain UTF-8 without a BOM. As a result, non-Latin characters appeared as garbled text in applications like Excel, which rely on the BOM for proper character interpretation.

Resolution

The issue is fixed in 16.0.1. You can now export incident lists to CSV files with UTF-8 BOM encoding, which ensures all non-Latin characters display correctly in applications like Excel.

To enable this functionality in version 16.0:

  1. Edit Enforce.properties at:

    \Program Files\Symantec\DataLossPrevention\EnforceServer\16.0.10000\Protect\config
  2. Add the following line at the end of the file:

    com.vontu.manager.restapi.csv_download_prependByteOrderMark = true
  3. Save the file.

  4. Restart the Symantec DLP Manager Service.

  5. Export a CSV file again and verify that all non-Latin characters are displayed correctly.

 

Additional Information

For reference:

Fixed issues in 16.0.1 MP1