DHCP traffic interruption during VM import task
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DHCP traffic interruption during VM import task

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Article ID: 427226

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • VM network access is lost for seconds during import of a powered on VM which uses DHCP.
  • The Import VM process may fail with an error: 

    "The following IP/MAC addresses have already been used by running virtual machines: MAC addresses: ##:##:##:##:##:## IP addresses: Use the 'Fence vApp' option to use same MAC/IP. Fencing allows identical virtual machines in different vApps to be powered on without conflict, by isolating the MAC and IP addresses of the virtual machines."

Environment

VMware Cloud Director 10.6.1

Cause

This issue can occur if there are DHCP IPv4 Bindings created for the VM on the Organization VDC network and that IP is appearing as allocated in the IP Usage IPv4 Allocations. During VM import, Cloud Director performs DHCP binding validation. As the IP is already present and showing as allocated it triggers a failure.

To validate the issue login to the Tenant UI and navigate to 'Networking -> Networks -> [network Name] -> IP Management -> DHCP -> IPv4 Bindings' and confirm the IP is present. Then select the 'IP Usage' page and confirm the IP is also present.

Resolution

To resolve this issue ensure that the VM IP is not already allocated on the Organization network DHCP bindings.

Workaround

If it's a requirement to have DHCP binding created before VM import, then you can login to NSX-T and create the DHCP binding. After VM import, Cloud Director and NSX-T would synchronize the configuration between products.