Unable to remediate the vCenter administrator password from SDDC manager with error 'Cannot connect to vCenter'
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Unable to remediate the vCenter administrator password from SDDC manager with error 'Cannot connect to vCenter'

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Article ID: 427212

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • Unable to remediate the vCenter administrator password from SDDC manager with error 'Cannot connect to vCenter'
  • vCenter is reachable via ping from the SDDC, and there are no firewall restrictions between the two environments.
  • The system clocks on the SDDC and vCenter are out of sync, as confirmed by the date command output on both appliances.
  • From SDDC Manager /var/log/vmware/vcf/operationsmanager/operationsmanager.log, there is error log below

    at com.vmware.vcf.passwordmanager.validation.utils.CredentialsValidationTaskExecutor$1.call(CredentialsValidationTaskExecutor.java: XX

Environment

VMware Cloud Foundation 5.x

Cause

A time skew between the SDDC and vCenter is causing authentication failures, rendering it impossible to remediate the vCenter password.

Resolution

Adjust the NTP settings on both the SDDC and vCenter to synchronize their system clocks, then retry the password remediation.