Service Catalog and Automic Integration
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Service Catalog and Automic Integration

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Article ID: 427134

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Updated On:

Products

CA Service Catalog CA Automic Workload Automation - Automation Engine

Issue/Introduction

Service Catalog offers the capability to integrate with Automic Integration

If issues are encountered, where do administrators look and what files will help troubleshooting?

Service Catalog view.log may show:

2026/01/20 16.00.12.788 ERROR [pool-4-thread-1] [ASOWebserviceManager] Automic login failed.
java.nio.channels.AsynchronousCloseException: null

Environment

Service Catalog 17.4.x

Automic Automation

Cause

This article will explain the applicable settings and files in both products.

This will help guide users where to investigate and files that will help Broadcom Support in troubleshooting.

Resolution

Service Catalog

On the Service Catalog side, this integration is configured in the UI under:

Administration > Options > Automic Automation 

The logs relevant to the integration should be in Service Catalog\logs\view.log

Automic Automation

The relevant configuration file from the ucsrv.ini file.

The following line indicates the port that Automic Automation is using for the web services integration

JCP.PORTS=2317

The relevant log files are in the Automation Engines Temp folder in WPsrv_log.

In new installations be sure to confirm that all traffic is allowed through firewalls and other security devices in the environment.

Example log in WPsrv_log indicating that the JCP process that Automic uses for web services is available on port 2317 (Default port)

20260125/200008.630 - 50               20260123/153526.801 - 42               JCP.PORTS=2317

Additional Information

Automic Automation Port and Firewall Configuration

Service Catalog Automic Automation Settings