VCF Operations for Logs displays error "Disabled - VC license type is not qualified for collection" for workload domain vCenter
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VCF Operations for Logs displays error "Disabled - VC license type is not qualified for collection" for workload domain vCenter

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Article ID: 427130

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Updated On:

Products

VCF Operations

Issue/Introduction

In VMware Cloud Foundation (VCF) Operations for Logs, when attempting to collect logs from a workload domain vCenter which is having valid 9.x licenses, the following error message is displayed: Disabled - VC license type is not qualified for collection
This issue typically occurs in the user interface when the application cannot properly communicate with the vCenter server to validate licensing or establish a connection.

Environment

VMware Cloud Foundation Operations for Logs 9.x

Cause

The primary cause of this error is a network communication failure. Specifically, Port 443 is blocked between the VCF Operations for Logs nodes and the workload domain vCenter server. 

Resolution

To resolve this issue, ensure that bidirectional communication is allowed on the port 443:

  1. Verify network connectivity between the VCF Operations for Logs cluster and the vCenter server.

    curl -vk https://<VC_FQDN or IP_Address>:443
  2. Work with your networking team to ensure Port 443 is open between the VCF Operations for Logs nodes and the vCenter server in both the directions.

  3. Once the port is opened, perform a reboot of the VCF Operations for Logs cluster to refresh the connection status.

  4. Verify that the vCenter status updates to "Collecting" to indicate active collection.

Additional Information

VMware Ports and Protocols - https://ports.broadcom.com/home/VMware-Aria-Operations-for-Logs