SPM Tests are stopping and are being duplicated when a new SPM Test Discovery is being done
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SPM Tests are stopping and are being duplicated when a new SPM Test Discovery is being done

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Article ID: 427112

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Updated On:

Products

Network Observability

Issue/Introduction

Service Performance Manager (SPM) tests may stop running following a SpectroSERVER restart. If a user attempts to run a new test discovery on the SPM Test Hosts to resolve this, duplicate tests are created in the environment. Initial investigation through debug logs (using rtm_debug=true in .vnmrc) revealed that these duplicate models are getting created because of missing Destination ID field in existing SPM Tests.

Environment

Spectrum 24.3.x 

Spectrum 25.4.x

Cause

Following a system restart, if two RTM tests share the same name, the RTM_Inventory occasionally builds with missing or blank Destination IDs. As a result, when discovery tests are run on those hosts, existing tests are not recognized, causing the code to create duplicate new tests.

Resolution

To resolve this issue, perform the following steps:

 

1. Identify and Delete Invalid Tests: Search for and delete all SPM tests that have a blank or missing Destination ID.

2. Restart Services: Restart the SpectroSERVERs and the Main Location Server (MLS).

 

Once the invalid tests have all been deleted and all SpectroSERVERs have been restarted, the duplicate tests should not be recreated during a SPM Test Discovery.

Additional Information

If the issue persists, please gather the following debug information and open a new support case.

 

1. Enable debug by adding rtm_debug=true to the .vnmrc file and restart the SpectroSERVER.

 

2. When the problem of duplicate test is recreated, please provide model_handle of rtm_test host, model handle of existing rtm_tests and new duplicate rtm_tests and VNM.OUT file in a new support issue.