Unable to fetch Applications error in the adminconsole browser after upgrading IDSP to 4.0.0
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Unable to fetch Applications error in the adminconsole browser after upgrading IDSP to 4.0.0

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Article ID: 427015

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Updated On:

Products

Symantec Identity Security Platform - IDSP (formerly VIP Authentication Hub)

Issue/Introduction

Running VIP Authentication Hub, in one of the 3 tenants, the applications cannot be seen when trying to display the applications in the adminconsole.

The secrets cannot be seen either in the adminconsole.

The browser reports the error:

Unable to fetch Applications.
[ txbId : <release>-ssp-<id>]

Accessing the tenant details by API reports the following message:

msg:'tenantPublicKeys20240830' Cache data not found, loading from DB

Environment

Symantec Identity Security Platform (IDSP) 3.4.6;

Cause

Previous version 3.4, a bad value has been uploaded as the SigningCert.

Resolution

As a workaround, re-import the certificate before the upgrade.

This will make the upgrade work.

Starting version 3.4, full verification of the certificate is done when updating using the API.

From version 3.4, no SigningCert corruption is expected.