Cannot Connect to SNMP Agent on VMware Cloud Director
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Cannot Connect to SNMP Agent on VMware Cloud Director

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Article ID: 426993

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to connect to the SNMP Agent on VMware Cloud Director.
  • Running the snmpwalk command against VMware Cloud Director fails with a No Response error.

Environment

VMware Cloud Director 10.6.x

Cause

This issue is typically caused by one of the following:

  • The monitoring server is unable to reach Port 161 on VMware Cloud Director.
  • The SNMP Agent settings on VMware Cloud Director are disabled.
  • The iptables on VMware Cloud Director is missing the rule for SNMP (UDP port 161).

Resolution

Confirm that the monitoring server has network connectivity to VMware Cloud Director via port 161.
In VMware Cloud Director, if there are no SNMP rules(udp dpt:161) in iptables, executing the following command will add SNMP rules to iptables:

# vicfg-snmp --disable
# vicfg-snmp --enable

The status of SNMP configuration being enabled or disabled in VMware Cloud Director can be verified using the following command:

# vicfg-snmp --show

Additional Information

Configuring Your VMware Cloud Director Appliance SNMP Agent