Repo_Sync failing on manager node
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Repo_Sync failing on manager node

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Article ID: 426926

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Updated On:

Products

VMware NSX

Issue/Introduction

When attempting to run a precheck prior to upgrading the NSX environment the following error is seen:

Unable to connect to File /repository/<NSX_Version_Here>/UC/bundle_type_pub on source <NSX_Manager_Here>. Please verify that file exists on source and install-upgrade service is up.

After the error is received, when reviewing the NSX Managers within the NSX UI the state for REPO_SYNC status (System > Appliances > View Details on the NSX Manager) is showing as FAILED:

Environment

VMware NSX 9.0.1.0
VMware VCF 9.0.1.0


 

Cause

It can be due to a few things:

The Install-Upgrade service is not running.
Missing files within the /repository directory within each NSX Manager.
The NSX Managers Upgrade Coordinator is showing different versions 

Resolution

Please follow the below KB article 
https://knowledge.broadcom.com/external/article/402081/nsx-upgrade-precheck-fails-with-reposito.html

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

1. The current version of NSX
2. The version being upgraded to
3. Current state of the REPO_SYNC on all NSX Managers
4. What steps have been done so far with regard to troubleshooting this issue
    Log Bundles for:
    -All NSX Managers and ensure that the Log age (days) option is set to All.  
    -For assistance with this process please refer to Collect Support Bundles