Duplicate Foundation Listing in Tanzu Hub
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Duplicate Foundation Listing in Tanzu Hub

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Article ID: 426916

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

Tanzu Hub may incorrectly list a single foundation twice under its Foundations section, even though only one connection is present. Both entries will also appear as members of the Foundation Group, even though the Foundation Group's own list contains only one foundation.

 

Cause

The exact cause was not definitively determined, but it's suspected that the duplication occurs during a foundation upgrade.

Resolution

To resolve the issue follow these steps:

  1. Remove the Platform Services tile from the foundation
  2. Delete the foundation connection from Tanzu Hub
  3. Re-add and Re-configure the Platform Services tile on the foundation

 

Additional Information

For further investigation into the timing of the foundation registration and record updates, you can check the control VM. Relevant logs showing when foundations were registered and records were updated are under the tanzusm namespace in the graphql-stitching-service and inventory-service pods.