CallAPI AS400 randomly fails to connect to CP with iRet: -1
search cancel

CallAPI AS400 randomly fails to connect to CP with iRet: -1

book

Article ID: 426890

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After the upgrade from 12.3.x to 21.x of the CallAPI and Agent AS400, the CallAPI randomly (multiple times a day) fails to connect to the CP with iRet : -1

Message . . . . :   2025.02.27 11:09:00 connection to : aaa.bbb.ccc.ddd:2217
Message . . . . :   2025.02.27 11:09:00 connect completed iRet : -1

Whereas the next CallAPI execution connects ok with the expected iRet : 0 :

Message . . . . :   2025.02.27 11:09:43 connection to : aaa.bbb.ccc.ddd:2217
Message . . . . :   2025.02.27 11:09:43 connect completed iRet : 0

Expected behavior: the connection to the cp should always work and not return -1
Actual behavior: multiple times a day the connection to the CP fails and no second connection attempt to one of the other CP is performed.

Environment

CallAPI (UCXBO41C) on AS400 21.x or 24.x

Cause

DE167874

A problem has been fixed where the CallAPI (UCXBO41C) on OS/400 could hang indefinitely when attempting to connect to an unavailable CP server, and would fail to try alternative CP servers from the configured CP list.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Agent AS400 (UCXBO41C)

Automation.Engine 24.4.4 - Planned release March 2026