Error: "The selected object is not applicable" in the default vCenter Services View
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Error: "The selected object is not applicable" in the default vCenter Services View

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Article ID: 426804

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When attempting to use the default "vCenter Services" View in Aria Operations, you encounter the following error after selecting a vCenter Server object: The selected object is not applicable

Additionally, logs on the Cloud Proxy (found in /storage/log/vcops/log/collector.log) may contain: [VC_SERVER] Unable to get response from the vMON services. Please check if the vCenter MP is configured with admin level credentials.

Environment

Aria Operations 8.18.x

Cause

This issue occurs because the vmonapi (VMware Service Lifecycle Manager API) service is in a stopped state on the vCenter Server Appliance, preventing Aria Operations from retrieving service health data. It can also be caused by the vCenter service account lacking membership in the SystemConfiguration.Administrators SSO group, which is required for the Infrastructure Health adapter to function correctly.

Resolution

To resolve this issue, you must ensure the service account has the required permissions and that the necessary API service is running on the vCenter Server.

1. Verify Permissions

Ensure the service account used by the vCenter Adapter in Aria Operations has the following:

  • The Administrator role assigned at the vCenter root level.
  • Membership in the SystemConfiguration.Administrators SSO group.

2. Restart the vCenter vMON API Service

  1. Log in to the impacted vCenter Server Appliance via SSH as root.
  2. Check the status of the vmonapi service:
    service-control --status vmonapi
  3. If the service is in a stopped state, start it:
    service-control --start vmonapi

3. Restart Aria Operations Adapters

  1. In Aria Operations, navigate to Administration > Integrations and restart the vCenter adapter instance for the affected vCenter.

    Note: Take note the value in the Collector column as you will need it for the last step


  2. Navigate to Operations > Configurations > Inventory Management > Adapter Instances.
  3. Locate the VMware Infrastructure Health adapter instance for the associated Collector or Cloud Proxy that collects from the affected vCenter and restart it using the "Stop/Start Collecting" buttons at the top of the Inventory page.

 

Validate that the issue is now resolved with your View or Dashboard that displays vCenter Services metrics.