The alarm 'Edge node NIC bond0.312 link is down' opens due to TimeoutExpired
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The alarm 'Edge node NIC bond0.312 link is down' opens due to TimeoutExpired

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Article ID: 426800

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Updated On:

Products

VMware NSX

Issue/Introduction

It is observed in /var/log/syslog on the edge node that Edge node NIC bond0.312 link is down and up intermittently.

<DATE_TIME> <HOSTNAME> NSX 3313 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="CRITICAL" eventFeatureName="edge_health" eventType="edge_nic_link_status_down" eventSev="critical" eventState="On" entId="<UUID>"] Edge node NIC bond0.312 link is down.

<DATE_TIME> <HOSTNAME> NSX 3313 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="CRITICAL" eventFeatureName="edge_health" eventType="edge_nic_link_status_down" eventSev="critical" eventState="Off" entId="<UUID>"] Edge node NIC bond0.312 link is up.

Environment

VMware NSX

Cause

A TimeoutExpired exception occurred while executing sudo cat /sys/class/net/bond0.312/operstate, as logged in /var/log/syslog.

<DATE_TIME> <HOSTNAME> NSX 3346 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="INFO" s2comp="fork-executor-1"] Exception caught when running cmd '{'cmd': ['sudo', 'cat', '/sys/class/net/bond0.312/operstate'], 'input': None, 'shell': False, 'timeout': 4, 'check_return': True, 'env': None, 'type': 0, 'proc_tree': False, 'text': True, 'timestamp': 3754277.10737247, 'seq': 1166876}': {'seq': 1166876, 'type': 0, 'executor': 1, 'timestamp': 3754277.107562466, 'execute_time': 4.027769919950515, 'exception': TimeoutExpired(['sudo', 'cat', '/sys/class/net/bond0.312/operstate'], 4)}

<DATE_TIME> <HOSTNAME> NSX 3313 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="INFO"] Command failed for interface: bond0.312, try: 1

Resolution

The TimeoutExpired exception can be triggered by DNS resolution timeouts; therefore, it is essential to check the following configuration settings.

1. Please ensure that the hostname is identical in both /etc/hosts and /etc/hostname.

2. Please verify that the configured DNS server has a valid A record for the Edge node.

3. Please confirm that the 'Search Domain Names' in the 'Change Node Settings' are configured correctly.