Phase 2 migration failed, database migration failed
search cancel

Phase 2 migration failed, database migration failed

book

Article ID: 426758

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention API Detection Data Loss Prevention API Detection for Developer Apps Virtual Appliance Data Loss Prevention Cloud Detection Service Data Loss Prevention Cloud Detection Service for API Detection Data Loss Prevention Cloud Detection Service for Endpoint Data Loss Prevention Cloud Detection Service for ICAP Data Loss Prevention Cloud Detection Service for REST Data Loss Prevention Cloud Package Data Loss Prevention Cloud Prevent for Microsoft Office 365 Data Loss Prevention Cloud Service for Discovery/Connector Data Loss Prevention Cloud Service for Email Data Loss Prevention Cloud Storage Data Loss Prevention Core API Detection Data Loss Prevention Core Package Data Loss Prevention Data Access Governance Data Loss Prevention Discover Suite Data Loss Prevention Endpoint Discover Data Loss Prevention Endpoint Prevent Data Loss Prevention Enforce Data Loss Prevention Enterprise Suite Data Loss Prevention for Mobile Data Loss Prevention Form Recognition Data Loss Prevention Network Discover Data Loss Prevention Network Monitor Data Loss Prevention Network Monitor and Prevent for Email Data Loss Prevention Network Monitor and Prevent for Email and Web Data Loss Prevention Network Monitor and Prevent for Web Data Loss Prevention Network Prevent for Email Data Loss Prevention Network Prevent for Email Virtual Appliance Data Loss Prevention Network Prevent for Web Virtual Appliance Data Loss Prevention Network Protect Data Loss Prevention Oracle Standard Edition 2 Data Loss Prevention Plus Suite Data Loss Prevention Sensitive Image Recognition

Issue/Introduction

You are attempting to upgrade to DLP 25.1 and receive the following failure in your MigrationUtility.log 

....

SEVERE: Failed to execute migration actions. Please refer to the log file for details
com.symantec.dlp.migrationcommon.MigrationException: Failed to run migration action "DatabaseUpdate"
at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.runMigrationAction(MigrationActionsExecutor.java:72)
at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.executeMigrationActions(MigrationActionsExecutor.java:118)
at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:193)
at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:116)
at com.symantec.dlp.migrationcommon.MigrationUtility.runMigrationUtility(MigrationUtility.java:127)
at com.symantec.dlp.enforceservermigrationutility.EnforceServerMigrationUtility.runMigration(EnforceServerMigrationUtility.java:49)
Caused by: com.symantec.dlp.migrationcommon.MigrationException: com.symantec.dlp.migrationcommon.MigrationException: Migration SQL script failed with 2 errors
at com.symantec.dlp.enforceservermigrationutility.actions.DatabaseUpdateMigrationAction.runAction(DatabaseUpdateMigrationAction.java:98)
at com.symantec.dlp.migrationcommon.MigrationActionsExecutor.runMigrationAction(MigrationActionsExecutor.java:65)
... 5 more
Caused by: com.symantec.dlp.migrationcommon.MigrationException: Migration SQL script failed with 2 errors
....
 
Search the log for any "ORA" errors and the MigrationUtility.log  file will show:
 
.... 

ERROR        : ORA-01427: single-row subquery returns more than one row
====================================================================================================

TASK_ID     : 8
TASK_NAME   : Data Migration
BATCH_NUM   : 1
ERROR_TYPE  : FATAL
ERRANT_STMT :
ERROR        : ORA-20001: UpgradeSchema_Data_Migration.Data_Migration: User-Defined Exception
====================================================================================================

....

Environment

DLP 16.0 RU1

DLP 25.1

Oracle 19c

Cause

The Phase 2 migration failure was caused by an `ORA-01427: single-row subquery returns more than one row` error during the `DatabaseUpdate` migration action

Resolution

Revert the database to the backup from before the migration was attempted.

Once the database is reverted and the environment is restored, open a case with Broadcom Support for further assistance