Unable to query vSAN health information. Check vSphere Client logs for details
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Unable to query vSAN health information. Check vSphere Client logs for details

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Article ID: 426749

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Updated On:

Products

VMware vCenter Server VMware vSAN VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

When navigating to vSAN Health, the error "Check vSphere Client logs for details" appears.

Environment

VMware vCenter Server 7.x

VMware vSAN 7.x and 8.x

VMware Aria Operations 8.x

Cause

This can occur for multiple reasons.  To find the most appropriate solution, please follow the details below.

Resolution

 

Cause 1: API overload occurring from Aria Operations calls to vCenter

Details: If you are running Aria Operations 8 against this vCenter and vSAN, review the below solution for symptoms and solution.

Solution: Unable to query vSAN health information due to Aria Operation API overload.

Cause 2: Missing KMS Permissions

Details: If your vCenter is configured with KMS, review the below solution for validations and solution.

Solution: Unable to query vSAN health information due to KMS/VECS permission issues.

Cause 3: API Calls to vsan-health were being blocked by intrusion detection

Details: The following error can be found in your /var/log/vmware/vsan-health/vsanvcmgmtd.log: HTTP Connection read failed while waiting for further requests. Additional validation can be found in the below solution.

Solution: Unable to query vSAN health information blocked by Intrusion Detection Software