After config change unable to connect to data base
search cancel

After config change unable to connect to data base

book

Article ID: 426746

calendar_today

Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

After re-configuring logging the Enforce UI becomes unavailable.

A plethora of errors are found including unable to obtain data base connection using descriptor found in JDBC.

26 Jan 2026 11:48:18,179- Thread: 17 INFO [org.apache.catalina.loader.WebappClassLoaderBase] Illegal access: this web application instance has been stopped already. Could not load [java.security.ProtectionDomain]. The following stack trace is thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access.

 

However if you follow to the top of the stack traces in Tomcat localhost you will find a key value of:

Access denied ("java.io.FilePermission")

Again this can be a red herring as there are no permissions issues.

Cause

Customer had added invalid logging entries to managerlogging.properties

Resolution

Revert the managerlogging.properties to the default restart services and service was restored.