Sensor shows "Queued" on Reports page on Central Manager
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Sensor shows "Queued" on Reports page on Central Manager

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Article ID: 426727

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Updated On:

Products

Security Analytics

Issue/Introduction

When trying to run a report on the Security Analytics Central Manager (CM), some data is returned, but if you select the icon that shows you the running report status, some of the sensors in the list show 100% complete, but others are showing 0% queued.  

Other users are not having any problems running similar reports.  When looking on the CM in /var/log/messages, some of these are displayed:

2026-01-26T15:42:02+00:00 hostname CakePhp[88877]: CakePHP Error: API ApiRequest.sendRequestWorker - Exception occurred (Appliance: hostname (xx), AuthID:xxx) Exception: Invalid permissions

Environment

Central Manager with multiple sensors.

The user has full permissions to run reports.

Cause

On occasion when a new user is added or a new sensor is added, the users and groups permission settings don't get synchronized to all the sensors.  

Resolution

The permission ACLs need to be forced to synchronize.  To do this, do the following:

  1. Log in to the GUI as admin on the CM.
  2. Make sure that there are no sensors selected.
  3. Go to Settings > Users and Groups
  4. On the Users tab, select the edit icon (pencil) next to the user that is having issues.
  5. Don't make any changes, but click Save
  6. Have the affected user log out of their CM session and log back in.
  7. Have them select all the sensors (or one of the sensors that was having the "queued" report issue)
  8. Select Analyze > Summary
  9. Under the Actions dropdown on the far right, select Clear Report Cache and then click OK.
  10. Perform the same search as before to see if the previous sensor stuck as Queued now changes to processing