No valid versions found for product "stemcells-windows-server" and product version "2019.xx"
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No valid versions found for product "stemcells-windows-server" and product version "2019.xx"

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Article ID: 426569

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

Concourse pipeline task failed on downloading the Windows stemcell from the S3 bucket.  A new Windows stemcell (e.g., v2019.93) was uploaded to the S3 bucket, but the pipeline task was not able to find it.  It was able to find the older version(s) only (e.g., v2019.88) as seen in the error log.

The error message from the pipeline task was:

selected worker: example-worker-1
5.2.1
+ '[' -z s3 ']'
...
+ om download-product --config config/pas-windows-stemcell.yml --vars-file vars/vars.yml --output-directory downloaded-product --stemcell-output-directory downloaded-stemcell --source s3
2026/01/20 05:19:41 no valid versions found for product "stemcells-windows-server" and product version "2019.93"
existing versions: 2019.88

 

Environment

VMware Tanzu Application Service

Cause

The file name of the Windows stemcell (in the S3 bucket) was not in the required format or has a typo, and this prevents the 'om download-product' procedure from finding the file.

Resolution

Rename the stemcell file according to the required format.  

If the stemcell file is:

bosh-stemcell-2019.93-vsphere-esxi-windows2019-go_agent.tgz

Then, it must have this file name in the S3 bucket:

'[stemcells-windows-server,2019.93]bosh-stemcell-2019.93-vsphere-esxi-windows2019-go_agent.tgz'

See the Setting up S3 for file Storage documentation about the required naming format.