エラー : vSphere HA reports that an agent is in the Agent Unreachable state
search cancel

エラー : vSphere HA reports that an agent is in the Agent Unreachable state

book

Article ID: 426499

calendar_today

Updated On:

Products

VMware vCenter Server VMware vCenter Server 8.0 VMware vSphere ESXi VMware vSphere ESXi 8.0

Issue/Introduction

免責事項:
これは英文の記事「Error: vSphere HA reports that an agent is in the Agent Unreachable state」の日本語訳です。
記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事を参照してください。

  • vSphere HA エージェントに到達できません
  • 影響を受けた ESXi ホストの [概要] タブで、次のエラーが表示されます:
    vSphere HA reports that an agent is in the Agent Unreachable state
  • 管理エージェントの再起動では問題は解決しません
  • Virtual Center サービスの再起動では問題は解決しません
  • fdm ログには以下のエントリが含まれる場合があります:
    Failed to SSL handshake; SSL.
    
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> The remote host certificate has these problems:
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> 
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> * Host name does not match the subject name(s) in certificate.
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> 
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> * unable to get local issuer certificate)
    YYYY-MM-DDTHH:MM:SS Er(163) Fdm[2101520]: --> [context]zKq7AVECAQAAABiabwEKZmRtAID8eoEBZmRtAIAbU2oBgHifagGApKJqAYBapGoBgJ4GbAGAgDdsAYBL1IwBAVJ4AGxpYnB0aHJlYWQuc28uMAACDzIPbGliYy5zby42AA==[/context] on handshake

 

Environment

VMware vCenter Server 7.0
VMware vCenter Server 8.0
VMware vSphere ESXi 7.0
VMware vSphere ESXi 8.0

Cause

この問題は、vCenter Server がプライマリホストおよびホスト上のエージェントに接続できないネットワーク障害が発生した場合、またはクラスタ内のすべてのホストが障害を起こした場合に発生する可能性があります。
 
また、ホスト上の エージェント が障害を起こし、watchdog プロセス がそれを再起動できない場合にも発生する可能性があります。
SSL 証明書が PSC ノードの PNID と一致しません。サブジェクト別名(Subject Alternative Name)が PSC の PNID と同一であるか確認してください。

Resolution

この問題を解決するには:

  1. vCenter Server がホストを「応答なし」として報告しているかどうかを確認します。詳細については、 Troubleshooting an ESXi host in a "not responding" state を参照してください。
  2. ホストが「応答なし」状態の場合、ネットワークの問題またはクラスタ全体の障害が発生しています。
  3. vCenter Server がホストを応答中として報告している場合:

    ・ root ユーザーで ESXi ホストに SSH 接続します。
    ・ /var/log/vpxa.log ファイルを確認し、vCenter Server とホスト管理エージェント (hostd) 間の通信に関連するエラーがないか確認します。
    ・ /var/log/fdm.log ファイル(障害ドメインマネージャーログ)を確認し、vSphere High Availability に関連するエラーがないか確認します。詳細については、『vSphere Availability Guide』を参照してください。

  4. 影響を受けたホストを右クリックし、vSphere HA の再構成 をクリックします。

追加のトラブルシューティング情報については、以下を参照してください:
ポート 8182 がファイアウォールによってブロックされていないか確認 してください