SPE error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory
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SPE error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory

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Article ID: 426443

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

During installation of Symantec Protection Engine (SPE) or while trying to restart services, use RestAPI or SSECLS, you see the following error message

error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory

Below is an example of the issue occurring when trying to restart SPE services.

[<user>@<Hostname>]# sudo /etc/init.d/symcscan restart

Symantec Protection Engine REST API is already running...
Starting Symantec Protection Engine, please wait...
/opt/SYMCScan/bin/symcscan: error while loading shared libraries: libnsl.so.1: cannot open shared object file: No such file or directory

Environment

  • RedHat 8.6 or higher
  • Rocky 9.x

Cause

libnsl.so.1 library is missing.

Resolution

To confirm if libnsl.so.1 is missing, type the following command

ll /lib64/libnsl*

This will list all libraries in lib64 that begin with libnsl.  If libnsl.so.1 is not listed when running the command above, it can be installed using this command

dnf install libnsl

After installing it, use the first command above to confirm libnsl.so.1 is now present.  After confirming it is now installed on the system, reinstall SPE.

Additional Information

You may experience other messages similar to the error above, but with different libraries or packages.  Ensure that all of the System Requirements are met before attempting to install SPE.

System requirements to install Symantec Protection Engine on Linux