Cannot install hub: Cannot create instance to NimBUS. Check if 'nimbus.dll' is properly registered
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Cannot install hub: Cannot create instance to NimBUS. Check if 'nimbus.dll' is properly registered

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Article ID: 426399

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You get the following error when trying to install a robot or hub

Initial Security
Cannot create instance to NimBUS.

Check if 'nimbus.dll' is properly registered.

Environment

DX UIM 23.4.*

Cause

nimbus.dll not registered

Resolution

To resolve this issue: 

1. Verify if there is any anti-virus running on the machine where this is being installed.  

If yes, deactivate or exclude UIM from scan for the install and also: 

2. Use the command prompt to navigate to the directory where the file nimbus.dll needs to be registered/unregistered resides.


Once there, use the following syntax:

To register a file:

regsvr32 filename (Note that regsvr32.exe is located in C:\Windows\System32\ directory)

cd "\Program Files (x86)\Nimsoft\lib"

C:\Windows\System32\regsvr32.exe nimbus.dll

Additional Information

NOTE: This solution may also apply for resolving the following error: 

 

Not all ocx/dll files are registered properly.

The file(s): C:\Program  Files (x86)\Nimsoft\lib\nimbus.dll