Unable to add compute manager to NSX due to stale extension
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Unable to add compute manager to NSX due to stale extension

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Article ID: 426389

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Updated On:

Products

VMware NSX

Issue/Introduction

 

  • An error occurs when attempting to add a compute manager to NSX stating that the compute manager is already registered with another NSX manager.

Error: "Compute manager <name> is already registered with other NSX manager <IP:port>" 
  • The error message references to a decommissioned NSX manager which was earlier attached to this vCenter.

  • A stale extension named com.vmware.nsx.management.nsxt is visible in the vCenter managed object browser.

 

Environment

VMware NSX

Cause

This issue occurs when the previous NSX manager is decommissioned without properly unregistering the vCenter server.The stale NSX extension from the previous instance remains on the vCenter and prevents the association with a new manager.

Resolution

To resolve this conflict, you must manually remove the stale extension using the vCenter Managed Object Browser (MOB).

Prerequisite: Access to the vCenter Managed Object Browser (MOB) must be enabled. Please refer to Broadcom KB 403417 for instructions on enabling MOB access.

Steps to Remove the Stale Extension:

  1. Log in to the MOB: Open a web browser and navigate to: https://<vCenter_Server_IP_or_FQDN>/mob

  2. Navigate to Extension Manager:

    • Click the content link located in the Properties table.

    • Click the ExtensionManager link located within the Properties table.

  3. Unregister the Extension:

    • Locate the Methods table at the bottom of the page.

    • Click the link for UnregisterExtension.

    • In the value field, enter the following extension key: com.vmware.nsx.management.nsxt

    • Click Invoke Method to remove the extension.

  4. Verify Removal:

    • Return to the ExtensionManager page.

    • Click the FindExtension link.

    • Enter the same value: com.vmware.nsx.management.nsxt

    • Click Invoke Method.

    • Result: The result should return void (or null), confirming the extension no longer exists.

  5. Retry Operation:

    • Go back to the NSX Manager UI.

    • Attempt to add the vCenter as a Compute Manager again.

Additional Information

If you still face the issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

 

Additional Information

Reference   :
1. Tech docs:Remove NSX Extension from vCenter