Usage Meter からの接続テスト実行時に「Failed to connect to the server: Connection reset」エラーが発生する
search cancel

Usage Meter からの接続テスト実行時に「Failed to connect to the server: Connection reset」エラーが発生する

book

Article ID: 426335

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

免責事項:これは英文の記事「Error 'Failed to connect to the server: Connection reset' when performing test connection from Usage Meter (410627)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • Usage Meter が Broadcom に使用状況データをアップロードしていません。 
  • Usage Meter から「TEST CONNECTION(接続テスト)」を実行すると、以下のエラーで失敗します。



  • Usage Meter アプライアンスの /var/log/vmware-um-platform/dss_error.log に、以下のエラーが記録されています。

    ERROR --- [https-jsse-nio-127.0.0.1-8052-exec-5] c.v.u.d.u.ConnectivityTesterService      : Connectivity test failed with IOException: Connection reset
    java.net.SocketException: Connection reset
            at java.base/sun.nio.ch.NioSocketImpl.implRead(Unknown Source)
            at java.base/sun.nio.ch.NioSocketImpl.read(Unknown Source)
            at java.base/sun.nio.ch.NioSocketImpl$1.read(Unknown Source)
            at java.base/java.net.Socket$SocketInputStream.read(Unknown Source)

  • Usage Meter から以下のコマンドを使用して curl 接続テストを実行すると、以下のエラーで失敗します。

    usagemeter@UM_hostname [` ]$ curl -v  https://eapi.broadcom.com:443 

    * Host eapi.broadcom.com:443 was resolved.
    * IPv6: (none)
    * IPv4: #.#.#.#
    *   Trying #.#.#.#:443...
    * ALPN: curl offers http/1.1
    * TLSv1.3 (OUT), TLS handshake, Client hello (1):
    *  CAfile: /etc/pki/tls/certs/ca-bundle.crt
    *  CApath: none
    * Recv failure: Connection reset by peer
    * TLS connect error: error:00000000:lib(0)::reason(0)
    * OpenSSL SSL_connect: Connection reset by peer in connection to eapi.broadcom.com:443
    * closing connection #0
    curl: (35) Recv failure: Connection reset by peer

Environment

VMware Cloud Foundation Usage Meter 9.0

 

Cause

この問題は、Usage Meter アプライアンスと Broadcom ポータル 'eapi.broadcom.com' 間のポート 443 での接続に問題があるために発生します。

Resolution

Usage Meter アプライアンスが Broadcom に使用状況データを送信するには、ポータル 'eapi.broadcom.com' への接続が必要です。ポート 443 でポータル「eapi.broadcom.com」への接続を確立するために、環境内のファイアウォールおよびネットワークポリシーを確認する必要があります。