Unable to delete 0 KB Replica VM in vSphere Client
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Unable to delete 0 KB Replica VM in vSphere Client

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Article ID: 426317

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Replica VM appears with 0 KB Size VMDKs in the vCenter inventory.
  • When attempting to remediate the issue, standard management operations, such as Delete from Disk, Snapshot Deletion, or Disk Consolidation fails
  • VM typically displays a 0 KB or 0 Size VMDK, indicating that the descriptor files are corrupted or inaccessible

Environment

  • VMware vCenter Server

Cause

  • If a replication cycle is interrupted due to network latency or storage timeouts, the descriptor files for the replica VMDKs may become corrupted, leading vCenter to report a 0 Size disk.
  • Active snapshots used for the replication process may leave persistent locks on the base VMDKs. Because vCenter perceives these disks as "in use" or "invalid," it prevents any deletion tasks to protect against accidental data loss.

Resolution

To resolve this safely detach a drive from Replica VM without deleting the actual vmdk files from the Datastore.

Follow the steps below:

  1. Locate the Replica VM in the Host Client inventory.
  2. Make sure Virtual Machine is on Powered Off State
  3. Right-click the VM and select Edit Settings.
  4. Identify all Hard Disks (VMDKs) associated with the Virtual Machine
  5. Select the Hard Drive, Click on "X" mark on right hand side and Detach the drive (Make sure not to check the box, where it says, delete files from Datastore, leave it unchecked)  
  6. Click on Save and exit
  7. Now Unregister the Replica Virtual Machine->right click and unregister the Virtual Machine from vCenter Inventory
  8. Reinitiate the replication again to create a new replica Virtual Machine