SPE crashes when scanning files using the RestAPI
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SPE crashes when scanning files using the RestAPI

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Article ID: 426316

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

You are suddenly unable to scan files using the Symantec Protection Engine (SPE)'s RestAPI. When reviewing the SPE logs you note entries similar to the following.

SSE######.log:

The Symantec Protection Engine has crashed

SPE_REST_API.log:

[http-nio-8008-exec-18] ERROR symantec.spe.filescanning.SPEFileModeScan:100 - SPEFileModeScan::scanFile(): Scan failed for :<FILE_NAME> ,null status received from Symantec Protection Engine.

/var/log/messages:

kernel: oom_kill_process.cold+0xb/0x10
kernel: [  pid  ]   uid  tgid total_vm      rss pgtables_bytes swapents oom_score_adj name
kernel: oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/session-6694.scope,task=symcscan,pid=3038421,uid=1000
kernel: Out of memory: Killed process 3038421 (symcscan) total-vm:86623588kB, anon-rss:62829824kB, file-rss:312kB, shmem-rss:25728kB, UID:1000 pgtables:163956kB oom_score_adj:0
kernel: oom_reaper: reaped process 3038421 (symcscan), now anon-rss:12kB, file-rss:312kB, shmem-rss:0kB

Environment

SPE 9.2.1/9.3.0 on Linux

Cause

A crash occurred due to an out of memory (OOM) error.

Resolution

Broadcom engineering has committed to resolving this issue in a future release. 

As a workaround, please restart the SPE service using the following command:

/etc/init.d/symcscan restart

If the workaround does not resolve the issue, or the issue continues to occur, please contact support for further assistance.