vCenter file-based backup fails during WCP service backup process
search cancel

vCenter file-based backup fails during WCP service backup process

book

Article ID: 426227

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

Prerequisites:

  • vCenter Server is configured to perform file-based backups.

  • After replacing vCenter Server certificates, the error "certificate signed by unknown authority" described in KB313182 was recorded.

  • Following the file-based backup failure, the following logs are observed in /var/log/vmware/applmgmt/backup.log:
    YYYY-MM-DDTHH:MM:SS.mmm [YYYYMMDD-HHMMSS-XXXXXXXX] [ComponentScriptsBackup:PID-YYYYYYY] [Log::run:Log.py:64]
     ERROR: {challenge : None, messages : [LocalizableMessage(id='vapi.security.authentication.invalid',
     default_message='Unable to authenticate user', args=[], params=None, localized=None)], data : None, error_type : UNAUTHENTICATED}
    YYYY-MM-DDTHH:MM:SS.mmm [YYYYMMDD-HHMMSS-XXXXXXXX] [MainProcess:PID-YYYYYYY] 
    [Proc::VerifyProcStatusAndGetArchive:Proc.py:171] INFO: Following error message isn't localized: stderr:Error during component wcp backup

 

Environment

VMware vCenter Server 8.x

Cause

The vCenter file-based backup process calls the WCP service during execution. However, because the WCP service is not functioning correctly due to the issue described in KB313182, the backup process fails.

Resolution

  1. Restart the Workload Control Plane (WCP) service by following the workaround steps provided in KB313182.

  2. After the service restart, manually execute the file-based backup and verify that it completes successfully.

Additional Information

File-Based Backup and Restore of vCenter Server

vCenter のファイルベース バックアップ処理で wcp サービスのバックアップに失敗する (426235) (Japanese)